1421. Accidental move-only library types due to new core language rules

Section: 26.6 [container.adaptors] Status: Resolved Submitter: DIN Opened: 2010-08-25 Last modified: 2016-02-10

Priority: Not Prioritized

View all other issues in [container.adaptors].

View all issues with Resolved status.

Duplicate of: 1350

Discussion:

Addresses DE-22, CH-15

With the final acceptance of move operations as special members and introduction of corresponding suppression rules of implicitly generated copy operations the some library types that were copyable in C++03 are no longer copyable (only movable) in C++03, among them queue, priority_queue, and stack.

[ 2010-10-26: Daniel comments: ]

Accepting n3112 should fix this.

[2011-02-17: Lawrence comments:]

The only open issue in CH 15 with respect to the concurrency group was the treatment of atomic_future. Since we removed atomic_future in Batavia, I think all that remains is to remove the open issue from N3112 and adopt it.

[2011-03-23 Madrid meeting]

Resolved by N3264

Proposed resolution:

See n3112