This page is a snapshot from the LWG issues list, see the Library Active Issues List for more information and the meaning of Resolved status.

1150. wchar_t, char16_t and char32_t filenames

Section: 27.9.5 [fstream] Status: Resolved Submitter: LWG Opened: 2009-06-28 Last modified: 2018-07-03

Priority: Not Prioritized

View all issues with Resolved status.

Discussion:

Addresses JP 73

Description

It is a problem from C++98, fstream cannot appoint a filename of wide character string(const wchar_t and const wstring&).

Suggestion

Add interface corresponding to wchar_t, char16_t and char32_t.

[ 2009-07-01 Alisdair notes that this is a duplicate of 454 which has more in-depth rationale. ]

[ 2009-09-21 Daniel adds: ]

I suggest to mark this issue as NAD Future with the intend to solve the issue with a single file path c'tor template assuming a provision of a TR2 filesystem library.

[ 2009 Santa Cruz: ]

NAD Future. This is a duplicate of 454.

[LEWG Kona 2017]

Recommend NAD: Needs a paper. Recommend providing overload that takes filesystem::path. Note that there are other similar issues elsewhere in the library, for example basic_filebuf. Handled by another issue.

Proposed resolution:

Resolved by the adoption of 2676.